geopsy command line usage under new version

This forum is dedicated to discuss all problems and suggestions related to the use of geopsy database and its plugins (array processing, H/V,...).
Post Reply
Posts: 13
Joined: Tue Oct 30, 2007 11:24 am
Location: University Potsdam

geopsy command line usage under new version

Post by bre »

I tried to run geopsy high-resolution FK from the command line, like always worked before, with a new version of geopsy
(GeopsyCore 3.3.0-snapshot-20101119 from geopsypack-2.1.0-snapshot-20101119 (built on 201011191741)
geopsy 2.7.0-snapshot-20101119 from geopsypack-2.1.0-snapshot-20101119 (built on 201011191741)).

Now, when using the command

geopsy -db /data2/NORSAR/noise/sac/Summer96.gpy -group doy153 -tool geopsyarray -slot 1 -param HRFK1996153-batch-26112010.log

I got the following error:

> Cannot determine byte order for SU format. > Cannot determine byte order for SEGY format. > Cannot determine byte order for PASSCAL SEGY format.
> ----WARNING--- Loading signal ...---- > Unknown format for /data2/NORSAR/noise/GEOPSY/summer96/doy153/HRFK1996153-batch-26112010.log
> geopsy: no signal available, check options -file, -db or -group, see -h for help

However, my data are in SAC-format (neither SU nor SEGY), the data base and group are both readable and the parameter file works fine when using the GUI. Still, geopsy tried to interpret the log file as a signal file.

The reason is probably a syntax change in geopsy - the correct command line call would be

geopsy -db /data2/NORSAR/noise/sac/Summer96.gpy -- -tool geopsyarray -slot 1 -group doy153 -param HRFK1996153-batch-26112010.log

(Note the "--" before all options related to the tool).

Post Reply