gpdcreport -m option

All geopsy forums are in their very early stage. So a restricted number of forums has been created. If your question does not fit into one of the available categories, post here.
vincent.metais
Posts: 3
Joined: Mon Mar 18, 2013 10:06 am

gpdcreport -m option

Postby vincent.metais » Mon Mar 18, 2013 11:12 am

Hello,

I think there is an error when we use the option -m (max misfit) with gpdcreport 0.3.6 . In fact, if we compare the result of this 2 command lines :

Code: Select all

   ./gpdcreport -vs  $"${path_resultat}"/"${name_report}".report > "${path_resultat}"/report_vs.txt
   ./gpdcreport -m $max_misfit -vs   $"${path_resultat}"/"${name_report}".report  > "${path_resultat}"/report_vs2.txt


we have profiles with a misfit lower than the variable "max_misfit" which don't appear in the report "report_vs2.txt". It is like if the -m option takes the variable "max_misfit" as an integer.

For now, I haven't found the bug in the cpp code.

Thank you

vincent.metais
Posts: 3
Joined: Mon Mar 18, 2013 10:06 am

Re: gpdcreport -m option

Postby vincent.metais » Wed Mar 20, 2013 7:44 am

Hello,

I have found the problem. Floating arguments have to be written with a coma ',' and not with a dot '.' . This is valid for all programs.


Return to “Miscellaneous”

Who is online

Users browsing this forum: No registered users and 1 guest