Laptop Ubuntu 12.04: make error

Post in this forum any question related to the installation on any of the supported platforms (Linux, Mac OS X, Windows)
agostiny

Laptop Ubuntu 12.04: make error

Postby agostiny » Fri May 17, 2013 12:43 pm

Hi Mark,

I have problem installing geopsy on my Laptop
I configured successfully, but the make command doesn't work

qmake -v
QMake version 2.01a
Using Qt version 4.8.1 in /usr/lib/x86_64-linux-gnu
agostiny@fast-and-furious:~/seisprog/geopsy/geopsypack-57items-src-2.5.0$ ./configure

Configure QGpCoreTools
Configure QGpGuiTools
Configure SciFigs
Configure DinverCore
Configure DinverGui
Configure dinver
Configure QGpCoreWave
Configure QGpGuiWave
Configure QGpCompatibility
Configure DinverDCCore
Configure DinverDCGui
Configure dinverdc
Configure dinverext
Configure dinvermatlab
Configure fastmap
Configure figue
Configure dfftpack
Configure mseed
Configure GeopsyCore
Configure GeopsyGui
Configure slink
Configure GeopsySLink
Configure GeopsySLinkGui
Configure geopsy
Configure ArrayCore
Configure ArrayGui
Configure geopsyarray
Configure geopsydamping
Configure geopsyfigs
Configure MonoStation
Configure geopsyhv
Configure geopsynr
Configure geopsyptmotion
Configure geopsyrefra
Configure geopsytfa
Configure gpcoord
Configure gpcurve
Configure gpdc
Configure gpdcmisfit
Configure gpdcreport
Configure gpdepths
Configure gpdistance
Configure gpec8
Configure gpell
Configure gpfksimulator
Configure gpgroup2phase
Configure gphistogram
Configure gplivemodel
Configure gpmodel2param
Configure gpparam2model
Configure gppoisson
Configure gpprofile
Configure gprandom
Configure gprefra
Configure gpreplace
Configure gpsh
Configure gpsignal
Configure gpsort
Configure gpspac
Configure gptarget
Configure gptime
Configure gptomoinfo
Configure gpviewdcreport
Configure kephren_plugin
Configure kephrenrtu
Configure max2curve
Configure spac2disp
Configure structureratios
Configure swim
Configure vslarray
Configure waran
Configure warand
Configure WaranCore
Configure warangps
Configure GpCoreTools
Configure warangpsd
Configure waranmon
Configure waranmond
Configure waranrouted


GeopsyPack is now configured for building, Just run 'make'.
Once everything is built, you must run either
$ su -c make install, if root privileges are needed;
or
$ make install, if user permissions are sufficient.

The current configuration options are stored in 'configure.cache'.
To change the configuration, run './configure [options]'.

agostiny@fast-and-furious:~/seisprog/geopsy/geopsypack-57items-src-2.5.0$ make
cd QGpCoreTools/ && make -f Makefile
make[1]: Entering directory `/home/agostiny/seisprog/geopsy/geopsypack-57items-src-2.5.0/QGpCoreTools'
make -f Makefile.Release
make[2]: Entering directory `/home/agostiny/seisprog/geopsy/geopsypack-57items-src-2.5.0/QGpCoreTools'
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIC -DMAKE_QGPCORETOOLS_DLL -DQT_NO_DEBUG -DQT_CORE_LIB -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4 -Isrc -Iui -I../include -Irelease -o release/AbstractFunction2.o src/AbstractFunction2.cpp
In file included from src/AbstractFunction2.cpp:28:0:
src/AbstractFunction2.h:31:18: fatal error: QtCore: No such file or directory
compilation terminated.
make[2]: *** [release/AbstractFunction2.o] Error 1
make[2]: Leaving directory `/home/agostiny/seisprog/geopsy/geopsypack-57items-src-2.5.0/QGpCoreTools'
make[1]: *** [release] Error 2
make[1]: Leaving directory `/home/agostiny/seisprog/geopsy/geopsypack-57items-src-2.5.0/QGpCoreTools'
make: *** [sub-QGpCoreTools-make_default-ordered] Error 2
agostiny@fast-and-furious:~/seisprog/geopsy/geopsypack-57items-src-2.5.0$


It says In file included from src/AbstractFunction2.cpp:28:0:
src/AbstractFunction2.h:31:18: fatal error: QtCore: No such file or directory

I do have the libqtcore well installed

Laptop:
uname -a
Linux fast-and-furious 3.2.0-41-generic #66-Ubuntu SMP Thu Apr 25 03:27:11 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Lenovo i7
Could you suggest something?
Thanks
Agostiny

agostiny

Re: Laptop Ubuntu 12.04: make error

Postby agostiny » Wed May 22, 2013 11:01 am

Problem solved!

following http://www.geopsy.org/wiki/index.php/In ... y_packages
I removed and reinstalled qt4-qmake
which qmake-qt4
sudo apt-get remove qt4-qmake
sudo apt-get install qt4-qmake
sudo apt-get install libqt4-dev
locate QtCore
./configure
make

The second problem was that zlib.h does not exist
I then installed
sudo apt-get install zlib1g-dev

followed by the make and sudo make install


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest