Problems with installing geopsy package in Ubuntu (11.10).

Post in this forum any question related to the installation on any of the supported platforms (Linux, Mac OS X, Windows)
shandou
Posts: 14
Joined: Wed Dec 14, 2011 7:24 pm

Problems with installing geopsy package in Ubuntu (11.10).

Postby shandou » Wed Feb 15, 2012 10:29 pm

Hey guys,

I need to install geopsy on a new Linux workstation that is running Ubuntu 11.10. I thought that I've got all of the components ready, and the configuration step went through without troubles. However, when I run the makefile, the compilation always fails at the very beginning -- It failed when compiling QGpCoreTools. I got pages of error messages that I have no idea what might be causing such problems. I attached the error messages from the compiling. Would you please help me figuring out what might be the culprits here?

Thank you very much!
Attachments
errorMessage.txt
(18.26 KiB) Downloaded 645 times

admin
Site Admin
Posts: 417
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: Problems with installing geopsy package in Ubuntu (11.10

Postby admin » Mon Feb 20, 2012 8:51 pm

Hi,

It looks like missing include files for low-level standard C libraries.
Apparently you are using Qt-4.8.0 in /usr/local/Trolltech/Qt-4.8.0, so you probably compiled Qt manually. I would not recommend this option with Qt-4.8.0. Remove /usr/local/Trolltech/Qt-4.8.0/bin from your PATH and install libqt4-dev (http://www.geopsy.org/wiki/index.php/Installing_Qt_binary_packages#Ubuntu)

I tried myself to build the latest release of Qt on an optimized gentoo system (sse flags on) and I ran into problems. I reported the problems to Qt teams and I'm waiting for Qt 4.8.1 or higher releases for more stability. In any case, you would have run into other compilation problems with Qt 4.8.0. These compilation problems will be fixed with the next minor release (2.4.4).

For the last course in Las Vegas, I compiled Geopsy successfully on a fresh ubuntu system (11.10). See http://www.geopsy.org/wiki/index.php/Ubuntu for the required packages. I've just fixed the documentation page about Qt binary installation under Ubuntu (http://www.geopsy.org/wiki/index.php/Installing_Qt_binary_packages#Ubuntu).

Under ubuntu unity, there is one issue about the sub menu bars that appear in graphic sheets under Geopsy. They hide the main menu bar and we found no way to restore it except by restarting geopsy. The next minor release (2.4.4) will have a patch to avoid the double bar under Ubuntu unity. The menu bar will be provided through a right click like under Mac OS X.

Syl
Posts: 4
Joined: Tue Jun 26, 2012 9:35 am

Re: Problems with installing geopsy package in Ubuntu (11.10

Postby Syl » Fri Jun 29, 2012 9:56 am

Hi,

I met the same issue when installing Geopsy on a fresh Ubuntu 12.04 system.
It was working just fine on Ubuntu 11.10 with qt 4.7.5 but with 12.04, the default install version of qt is 4.8.1...and there is obviously a problem with qt versions higher than 4.8.0.
I managed to install qt4-qmake with a older version, but I cannot do the same trick with liqt4-dev since Ubuntu now use qt for Unity...If I uninstall it I will lose all my Unity interface (which now I'm kind of familiar with).
I found a temporary solution by installing Geopsy on a Virtualbox with Ubuntu 11.10...but this is not suitable for long term.
Do you have any idea of how or when we can pass through this compatibility problem (e.g. next release 2.4.4) ?

Thanks

Syl

admin
Site Admin
Posts: 417
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: Problems with installing geopsy package in Ubuntu (11.10

Postby admin » Mon Jul 02, 2012 8:45 am

There are good chances that the last geopsy update solves these issues, you can keep Qt 4.8. It was available for Windows last Friday, I've just published the source package. Thanks for your feedback.

admin
Site Admin
Posts: 417
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: Problems with installing geopsy package in Ubuntu (11.10

Postby admin » Mon Jul 02, 2012 11:23 am

Just a note: under Ubuntu Unity (since Ubunty 11.04?) you'll get trouble with H/V results and all graphic sheets embedded in a main window (geopsy and dinver). The secondary menubar will replace the main one and the main menu bar will not be accessible anymore. You can fix it at compile time by adding the define flag "UBUNTU_UNITY". It prevents secondary menubars, replaced by a contextual drop-down menu (right click on sheet content) like for Mac OS X users.

./configure -D UBUNTU_UNITY
(works only with geopsy>=2.4.4)

For next releases, this option is activated in a more automatic way.

Syl
Posts: 4
Joined: Tue Jun 26, 2012 9:35 am

Re: Problems with installing geopsy package in Ubuntu (11.10

Postby Syl » Wed Jul 04, 2012 3:08 pm

Thanks, it's working just fine with the new release!

njlindsey
Posts: 2
Joined: Thu Sep 20, 2012 8:44 pm

Re: Problems with installing geopsy package in Ubuntu (11.10

Postby njlindsey » Mon Sep 24, 2012 6:49 pm

Hi,

I am a new user of Geopsy and have been experiencing difficulty installing the toolkit from src.

Here is my system info if you need that:
GNOME 2.32.1 (Ubuntu 2011-04-14)
Kernal 3.0.0-25-generic (#41-Ubuntu SMP Mon Aug 13 17:58:59 UTC 2012)
OS Type: Linux
GCC version: 4.6.1 (x86_64-linux-gnu)

I installed all of the packages using the Installation guide provided on geopsy.org, including qt-everywhere-opensource-src-4.8.2. I successfully configure the items in geopsypack-57items-src-2.4.4, but when I attempt a 'make', a few of the items make correctly and then I get the error message attached.

Perhaps my $PATH is incorrectly designated? What am I doing wrong?

Thanks for your help!
Nate
Attachments
geopsy_make_error_message.txt
(4.88 KiB) Downloaded 548 times

admin
Site Admin
Posts: 417
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: Problems with installing geopsy package in Ubuntu (11.10

Postby admin » Wed Sep 26, 2012 10:20 am

It looks like that there missing symbols in some Geopsy libraries, and all symbols belong to Qt libraries. I cannot give you a solution directly, I need more information.

Can you issue the following commands and post the result:
qmake -v
ldd /home/hunter/Desktop/geopsypack-57items-src-2.4.4/lib/libSciFigs.so

You could have skipped the installation of Qt from source. You can use Qt shipped with Ubuntu, with 11.10 this is not too old.

njlindsey
Posts: 2
Joined: Thu Sep 20, 2012 8:44 pm

Re: Problems with installing geopsy package in Ubuntu (11.10

Postby njlindsey » Thu Sep 27, 2012 4:27 pm

Ok, thanks for your help. Here is the printout:


qmake -v
QMake version 2.01a
Using Qt version 4.7.4 in /usr/lib/x86_64-linux-gnu
ldd /home/hunter/Desktop/geopsypack-57items-src-2.4.4/lib/libSciFigs.so
linux-vdso.so.1 => (0x00007fffc99f0000)
libQGpCoreTools.so.1 => not found
libQGpGuiTools.so.1 => not found
libQtSvg.so.4 => /usr/lib/x86_64-linux-gnu/libQtSvg.so.4 (0x00007f6434fcd000)
libQtGui.so.4 => /usr/lib/x86_64-linux-gnu/libQtGui.so.4 (0x00007f64342ed000)
libQtCore.so.4 => /usr/lib/x86_64-linux-gnu/libQtCore.so.4 (0x00007f6433e4c000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f6433b44000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f64338c0000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f64336aa000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f6433308000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f64330f0000)
libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f6432eba000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f6432c9c000)
libaudio.so.2 => /usr/lib/x86_64-linux-gnu/libaudio.so.2 (0x00007f6432a83000)
libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f643278d000)
libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f6432564000)
libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f64322cc000)
libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f643207b000)
libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007f6431e72000)
libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007f6431c58000)
libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007f6431a48000)
libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f643183c000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f6431629000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f64312f1000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f64310ec000)
libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f6430ee7000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f6430cdf000)
/lib64/ld-linux-x86-64.so.2 (0x00007f6435619000)
libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f6430ab4000)
libXt.so.6 => /usr/lib/x86_64-linux-gnu/libXt.so.6 (0x00007f643084f000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f643064c000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f643040f000)
libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f6430207000)
libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f6430001000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f642fde5000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f642fbde000)

admin
Site Admin
Posts: 417
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: Problems with installing geopsy package in Ubuntu (11.10

Postby admin » Sun Sep 30, 2012 12:50 pm

As you mentioned Qt 4.8.2 and ldd/qmake report links to Qt 4.7.4, you may have a mix a Qt version. Honestly, I do not have the solution. Maybe, you can try

Code: Select all

make clean
make
make install


Does it worked for you?


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest